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1.0 INTRODUCTION 
OPN_SLM is a service level monitoring system which uses barcodes to monitor: 
 

• Attendance at individual Sites/ Locations 

• Time spent at individual Sites/ Locations 

• Overall time taken visiting multiple Sites/ Locations (with confirmation of attendance and/or 
time spent at the associated individual Sites/ Locations) 

 

The system is based on the OPN2001 barcode data collector. These compact units will be used to 
scan barcoded location codes as the service being monitored is performed. The scanned location 
codes will be date/ time tagged by the data collector and stored in internal memory for subsequent 
downloading into the system database. 
 

A utility is also available for remote field staff to allow the OPN2001 data collectors to be downloaded 
to a simple data file which can be forwarded to head office for importing into the OPN_SLM data-
base.  
 

OPN_SLM incorporates a range of standard reports providing detailed feedback of the service levels 
achieved. 



1.0 INSTALLATION  
 

1.1 INSTALLING THE SOFTWARE 
 

To install OPN_SLM Service Monitoring software: 
 

1) Run the installer setup.exe from the system CD and follow the prompts 
2) Run CRRedist2005_x86.exe to install the components use by the reporting module. 
 

Once installed create the system database as shown below: 

NOTE: The software will by default run in Demonstration mode. In this mode the max. number of 
records in the database will be limited.  
To licence the software for full operation see section 9.0 below 

2. Click Create Database 

3. Specify a location and name for the database file and click OK.  
The default location for the database is: 
C:\ProgramData\Electronic Reading Systems Ltd\OPN_SLM 

4. The database has been successfully 
created. Click OK to continue. 

5. Click Yes to make this the active database 
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1. Click Tools > Options from 
the program menu bar  
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1.2 INSTALLING THE OPN2001 DRIVERS 
These drivers are used by OPN_SLM when downloading the OPN2001 data collectors. 
To install the drivers run the Opticon Driver Installer (USB Drivers Installer.exe) from the system CD 
and proceed as shown below.  

1) Click Run 

2) Click OK  

3) Click OK  

4) Click OK  

5) Click OK. 
The OPN drivers are now installed  

Note: Do not connect the OPN2001 data 
collector onto your PC until after the drivers 
have been manually installed below 

1.2.1 CHECKING THE DRIVER INSTALLATION 
The driver installations can be checked via the Windows Hardware Device Manager as follows: 

Connect the scanner to the PC and from the Windows Device 
Manager expand the Ports section. The scanner will be listed 
with a description similar to: 
 

Opticon USB Code Reader (COMxx) 

The Windows Device Manager may be accessed by 
right-clicking My Computer then selecting Properties 
from the drop down menu. 
Go to the Hardware Tab and click Device Manager 
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2.0 CONFIGURING OPN_SLM 
OPN_SLM allows a database of operators and a database of Locations to be configured. 
 
2.1 CONFIGURING THE OPERATORS 
Individual OPN2001 data collectors may be allocated to operators or teams of operators allowing 
both monitoring of the service level and logging of the specific operator or team providing the service. 
 

Allocating data collectors to operators is not mandatory. If the operators are not included in the                          
operator database the Service Level will still be monitored, however the transactions will be                              
anonymous. 
 

The operator database may be initialised manually via the PC keyboard (See section 2.1.1 below) or 
by import from a suitable data file (See Section 2.1.1 below). 
 
2.1.1 MANUALLY CONFIGURING THE OPERATORS 
To configure operators proceed as follows: 

2. Click Add New to add a new operator 

3. Enter the relevant Operator details and click OK. 
 

Note: Operator ID and Serial No. are mandatory fields and must be unique. If 
not using Operator IDs this field may hold a sequential number or a copy of the 
Serial No. 
 

If allocating data collectors to teams simply leave the Operator Name blank (or 
repeat the team name in this field). The Operator ID could in this case hold a 
Team ID, a simple sequential no., or a copy of the device serial no. for example 

4. The operator is entered into the database. 
To add more operators repeat steps 1 - 2 as necessary and click ‘x’ 
to exit when finished. 
 

To edit or delete an existing Operator, click to highlight the relevant 
operator in the list and click Edit or Delete as appropriate. 

1. Click Edit > Operator/ Serial No. Links 
from the program menu bar 
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2.1.2 IMPORTING THE OPERATORS 
The operator database may also be initialised by importing the operator details from a simple text file. 
 

To import operator details click File > Import > Operator/ Serial No. Link File from the program 
menu bar and pro-

1. Browse to the relevant import file and click 
Open to import. 
 

NOTE: The imported data will overwrite existing 
operator data 

The import file must be a simple comma delimited data file containing data records in the following 
format: 

Operator ID, Operator Name, OPN2001 Serial No, Team Name 
 
Example import file format: 
 

LLY122,Lilley Yates,899034,TEAM-2 
PO393877,Peter Offley,467842,TEAM-5 
RETR54362T,RUPERT RANDOLF,736482, 
NBB323,Norman Bates,343242,TEAM-10 
OPIUY,,341231, 
VBJGHIO,Vinney Jones,383278, 
JD004,,367812,TEAM-JD 
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2.2 CONFIGURING THE LOCATIONS 
The Locations database includes those locations at which the service level will be monitored.                                   
A suitable barcoded Location Code label will be fixed at these locations and scanned by operators 
when performing service activities at that location. (See Section 3.0 below LOCATION BARCODES) 
 

The Locations database may be initialised manually via the PC keyboard (See section 2.2.1 below) 
or by import from a suitable data file (See Section 2.2.2 below). 
 
2.2.1 MANUALLY CONFIGURING THE LOCATIONS 
To configure the locations proceed as follows: 

2. Click Add New to add a new location 

2. Enter the relevant Location details and click OK. 
 

 NOTE: Up to 4 Additional Fields may be added to each Location. These 
might represent a customer name or Account Code/ Contract ID for exam-
ple and may be used when reporting to select a specific group of locations 
(eg: all locations for a specific customer or contract etc.) 
The field names for the Additional Fields may be configured (see section 
2.2.3 below) 

3. The operator is entered into the database. 
 

To add more locations repeat steps 1 - 2 as necessary and click ‘x’ to 
exit when finished. 
 

To edit or delete an existing Location, highlight the relevant Location 
in the list by clicking and click Edit or Delete as appropriate. 

1. Click Edit >  Locations Data from the 
program menu bar  
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2.2.3 CONFIGURING THE ADDITONAL FIELD NAMES FOR LOCATIONS 
To configure the additional field names click Tools > Options from the program menu bar and select 
the Additional Fields Tab: 

2. Enter the relevant field names into the boxes provided and click OK when finished. 
 

These field names will then be used for display and reporting purposes. 

1. Browse to the relevant import file and click 
Open to import. 
 

NOTE: The imported data will overwrite existing 
Locations data 

2.2.2 IMPORTING THE LOCATIONS 
The Location database may also be initialised by importing the Location details from a simple text 
file. 
 

To import operator details click File > Import > Locations Data File and proceed as follows: 

The import file should be a simple comma delimited data file with data records in the following format: 
 

Location Code, Location Name, Addtnl. Field 1, Addtnl. Field 2, Addtnl. Field 3, Addtnl. Field 4  
 
Example import file format: 
 

LOC001,Drawing Room,AF1-Test1,AF2-Test1,AF3-Test1,AF4-Test1 
LOC002,Dining Room,,,AF3-Test2, 
LOC003,Kitchen,,,, 
LOC004,Reception,AF1-Test4,,,AF4-Test4 
 

1. Click Tools > Options from the program menu bar 
and select the Additional Fields Tab 
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3.0 LOCATION BARCODES 
In use the OPN2001 will be used to scan barcoded Location Codes to confirm attendance at those  
locations by the operator and if required to log the time spent at the location, or the overall time spent 
visiting numerous locations.  
 

OPN_SLM supports 3 scanning modes which are automatically handled by the system depending on 
the format of the scanned Location Barcode. These modes allow: 

• Attendance Monitoring 

• Time Duration Monitoring per Location 

• Time Duration Monitoring across Multiple Locations    
 

The scanning modes above can be freely ‘mixed’ as necessary to provide the required level of                  
monitoring.  
 
3.1 DATA FORMATS FOR LOCATION CODES 
To automatically distinguish between the 3 scanning modes OPN_SLM defines specific data formats 
for the barcoded Location Codes as summarised below. (For illustrative purposes below we have 
used an example Location Code ‘LOC001’) 
 

If using the barcode printing facility in OPN_SLM these formats will automatically be handled by the 
software as required (see Section 4.0 below). These formats should however be considered if using 
other software packages to generate the Location barcodes. 
 
 

3.1.1 ATTENDANCE MONITORING 
In this case the operator simply scans a barcoded Location Code on arrival at the location to confirm 
attendance at that location. 
 

The Location barcode used will be the unmodified Location Code from the Locations Database: 

For simple attendance monitoring the Location                   
barcodes simply represent the Location codes as            
entered into the Locations database. 

3.1.2 TIME DURATION MONITORING PER LOCATION 
In this case the operator scans a ‘Start Location’ barcode on arrival at the location and a separate 
‘Finish Location’ barcode on departure allowing the operator’s attendance and the duration of the 
visit to be monitored. 
 

The barcodes used for this scanning mode use the Location Code from the Locations database with 
a leading ‘+’ or ‘-’ character to distinguish the START and finish barcodes: 

FINISH LOCATION 

START LOCATION 
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Alternative Formats: 
The unmodified Location Code (as used for simple Attendance Scanning) can also be used as the 
Start Location barcode. 
 

An alternative fixed format is also available for the Finish Location barcode simply comprising the 
word ‘FINISH’. The alternative ‘FINISH’ format allows the option for only the Start Location barcodes 
to be fixed at the various locations, but for the Finish Location barcode to be scanned from a                              
supervisor menu card, for example. 

3.1.3 TIME DURATION MONITORING OVER MULTIPLE/ GROUPED LOCATIONS 
This facility provides a measure of the time spent on an overall job or task which comprises of multi-
ple locations. In this case the operator will scan a ‘Group Start’ barcode at the commencement of the 
task and a ‘Group Finish’ barcode when the task is completed.  
 

Between the Group Start and Group Finish barcodes the operator will in general proceed to scan 
location barcodes as detailed in 3.1.1 and 3.1.2 above to log attendance at, or measure time spent at 
each individual location within the overall task. 
 

To use this facility it is necessary to define a ‘Location’ which represents the start and finish point for 
the overall task. This does not have to be a ‘physical’ location, it is merely used to provide the                       
required Group Start and Finish codes. 
 

The Group Start and Group Finish barcode formats are defined as follows: 
 

Group Start Barcode: - This will be the Location Code from the OPN_SLM database preceded by a 
‘/’ (forward slash) character 
 

 

Group Finish Barcode:- This will be the Location Code from the OPN_SLM database preceded by a 
‘.’ (full stop) character 
 
Note: In the case of Group Start and Finish there are no alternative Start and Finish codes as de-
fined for Location Start and Finish 

ALTERNATIVE START LOCATION ALTERNATIVE FINISH LOCATION 

FINISH LOCATION 

START LOCATION 
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4.0 BARCODE PRINTING 
OPN_SLM includes a facility to print location barcodes using the Toshiba B-EV4T desktop label 
printer. This option may be used to generate 70mm x 32mm self adhesive paper or polyester labels 
including (where necessary) the relevant formatting characters as summarised in section 3.0 above. 
 

To print barcoded location labels click Tools > Barcode printing and proceed as shown below: 

1. Configure the format of the Location Labels. Use the relevant 
drop down list to select up to 4 lines of data from the Locations                     
database for the labels. Once configured this format will remain as 
default until subsequently changed. 
 

In this example the labels will include the Location code (as                   
barcode), the location code (as text) plus the Location Description 
and customer name (as text). 

2. Use the search facility to display a specific Location code as 
required, or use the * wild card to display all Locations. 
 

Highlight the Location(s) to be printed, or click the Select All 
box to print all Locations. 

3. Use the drop down list to select the type of location barcodes required. ie: simple 
Location barcodes only, or Location Start and Finish label pairs, or Group Start and 
Finish label pairs. Note that the relevant formatting characters will automatically be 
included when the barcodes are printed. 

4. Specify the no. of copies required 
and click Print to generate the labels 

The label printing option works with the B-EV4T               
thermal label printer with 70mm x 32mm paper or 
polyester labels 
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5.0 DOWNLOADING THE OPN2001 DATA COLLECTOR 
In use the OPN2001 data collector will be used to monitor service levels by scanning location                    
barcodes.  
To download the stored barcode data from the data collector proceed as shown below. 
 

Note: The Transfer Data facility will automatically synchronise the OPN2001 real-time clock. Before 
using the data collectors we therefore recommend using the Transfer Data function to ensure the all 
the devices are synchronised and set to the correct time 

2. If required set the system to ‘Ask for a reference before each 
download’ and connect the OPN2001 to a suitable USB port on the 
PC. 
 

The optional download Reference may be used to select data when 
reporting 

1. Click Transfer Data 

3. OPN_SLM connects to the data collector 
and downloads stored data. 
The real-time clock in the data collector will 
also be synchronised to the PC clock. 

4. Enter a download reference (if enabled). 

5. Download successful. Click OK 

6. disconnect OPN2001 
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6.0 EDITING THE DOWNLOADED TRANSACTIONS 
The downloaded data may be manually edited if required. Existing transactions may be edited or                   
deleted and new transactions manually entered as required. 
 

To edit the transactions click Edit > Transactions from the program menu and proceed as follows: 

Highlight a single transaction and click Edit to amend, or highlight one 
or more records and click Delete to remove those records from the    
database. 
 

Alternatively click Add New to manually enter a new transaction. 
 

Note: To order the Edit Transactions grid by any specific data field click 
on the relevant field header. 

Transactions from simple ‘attendance’ scanning  
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7.0 EXPORTING THE TRANSACTIONS 
The stored transactions may be exported from the OPN_SLM in text or Excel format. 
To edit the transactions click File > Export > Transactions from the program menu and proceed as 
follows: 

1. Select the date range to be exported 
if required and click OK 

2. Specify the location, name and file 
type for the exported data file and click 
Save to generate the file. 
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8.0 REPORTING 
A selection of standard reports are incorporated into the system. To run reports proceed as follows: 

1. Click Reports 

2. Select the report type required from the 
list, and selection criteria for the data. Click 
Run Report to generate the report  

3. The report is generated. 
Note: Any data records which have been manually en-
tered or edited (see section 7.0 below) will be highlighted 
with an asterisk in the left hand column. 
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9.0 LICENCING THE SOFTWARE 
After initial installation the software will run in demonstration/evaluation mode where the max.                  
number of records in the database will be limited. 
 

To licence the software for normal use click Help > Licence Management and proceed as follows: 

1. Click Change Licence 

2. OPN_SLM generates a random Keycode. 
Contact ERS for the relevant release code  


